Upgrading to Demandbase IP-API v3

  • Updated

Demandbase recently updated our IP-API, which identifies website visitors in real time. The new version, IP-API v3, enhances data consistency across products, improves firmographic accuracy, and doubles domain coverage. It also introduces a unified company ID and a corporate hierarchy that includes parent and ultimate parent IDs. 

The IP-API update adds new firmographic attributes and deprecates attributes previously available in IP-API v2. For more information, see Reference: Firmographic Attributes Overview for Demandbase IP-API v3 (Updated Version).

Since the Demandbase Tag and specific Demandbase integrations use firmographic attributes for account identification (IP matching), the IP-API update may require you to take action. After Demandbase updates your tenant to IP-API v3, refer to the following sections for the actions you need to take for your integrations or features.

Important: The IP-API update doesn't impact any integration (e.g. CRM or MAS integrations) or Demandbase product (e.g. Data Stream) that is not listed below.

Google Analytics 4 Integration

If you integrate Demandbase with Google Analytics 4 (GA4), you can make the following changes related to the new and deprecated attributes in IP-API v3.

  • New Attributes: After Demandbase updates your tenant to IP-API v3 and the new attributes are available in the new API response, add them to your GA4 integration.
  • Deprecated Attributes: Update your GA4 integration by removing the deprecated attributes.

For more information about the GA4 integration, see the following articles:

Important:

  • The changes to your integration are optional. If you currently use any of the deprecated attributes, the integration continues to work after Demandbase updates your tenant to IP-API v3. However, the deprecated attributes will no longer send any company data to GA4. 
  • Demandbase does not need to take any action after you make changes to your GA4 integration.

Adobe Analytics Integration

If you integrate Demandbase with Adobe Analytics, see the following articles for information about updating your integration.

Demandbase Forms Enrichment

If you use Demandbase Forms Enrichment, you can make the following changes related to the new and deprecated attributes in IP-API v3.

  • New Attributes: After Demandbase updates your tenant to IP-API v3 and the new attributes are available in the new API response, add them to your Forms Enrichment configuration.
  • Deprecated Attributes: Update your Forms Enrichment configuration by removing the deprecated attributes.

After you make changes to your configuration, go to the Review and Activate tab for the Forms Enrichment and click Activate. For more information, see Set Up Demandbase Forms Enrichment.

Once Demandbase receives the changes to your configuration, a member from the Demandbase Implementation or Support team will follow up with you via email.

Important: The changes to your Forms Enrichment configuration are optional. If you currently use any of the deprecated attributes, your Forms Enrichment continues to work after Demandbase updates your tenant to IP-API v3. However, the deprecated attributes will no longer send any company data for your Forms Enrichment.

Demandbase Site Customization

If you use Demandbase Site Customization to personalize web experiences, you do not need to take any action for the IP-API update. 

If you use a third-party integration that uses firmographic attributes such as industry and sub-industry to personalize web experiences, you may need to make changes to the integration. 

For the latest list of industries and sub-industries, see Reference: Sales Intelligence Industries and Sub-Industries List. If the industry or sub-industry values your integration uses have changed, you need to update your web experiences with the latest values. For example, if your integration uses the Software & Technology industry, you may need to change the value to Computer Software

Account Connector Partner Integrations

If you use the Demandbase Account Connector to integrate with one of our partners, the action you need to take depends on the integration. Our partners are in the process of upgrading their Demandbase integrations to support IP-API v3.

The following table shows the upgrade status for each integration as of May 15, 2024.

Partner Integration Upgrade Status
PathFactory Upgraded
Qualified Upgraded
Drift Not Upgraded
Folloze Not Upgraded
Uberflip Not Upgraded
Optimizely Not Upgraded
Ion Interactive Not Upgraded
VWO Not Upgraded

If the integration upgrade status for your integration is Upgraded, take the following actions:

  • Integration Update: Log in to the integration platform and toggle on DEMANDBASE V3 to use the updated version of the IP-API.
    Partner Int IP-API Toggle.png
  • New Attributes Update: After Demandbase updates your tenant to IP-API v3 and the new attributes are available in the new API response, add them to your integration.
  • Deprecated Attributes Update: Update your integration by removing the deprecated attributes.
  • Industry and Sub-Industry Update: If your integration uses firmographic attributes such as industry and sub-industry, you may need to make changes. For the latest list of industries and sub-industries, see Reference: Sales Intelligence Industries and Sub-Industries List. If your industry or sub-industry values have changed, you need to update your integration with the latest values. For example, if your integration uses the Software & Technology industry, you may need to change the value to Computer Software.

If the integration status for your integration is Not Upgraded, you do not need to take any action at this time. Note that integrations that haven’t been updated continue to return firmographic attributes from the previous version of the IP-API.

Important: After Demandbase updates your tenant to IP-API v3, partners that haven’t upgraded their integrations cannot be selected from the Integration Name drop-down list on the Account Connector page. If you want to set up a new integration with one of these partners, you must first send an email to accountconnector@demandbase.com.

Partner Int Message.png

Was this article helpful?

0 out of 0 found this helpful